1. Welcome to The Salty Box, a forum to discuss everything related to Marine & Reef Fish keeping in a friendly surrounding.

    Your voice is missing! You will need to register to be able to join in discussions with others.

    We hope to see you as a part of our community soon

    Dismiss Notice

Poly Lab Medic And Ammonia Spike

Discussion in 'Help and Advice' started by damo666, Jan 26, 2019.

  1. damo666

    damo666 Registered

    Joined:
    Dec 20, 2016
    Messages:
    264
    Likes Received:
    17
    Right, got a problem and not sure if I've got the experience to decide on the best cause of action despite reading all manner of things. Have a blenny flicking like crazy, never seen a spot on it but ich kicked in on other tank mates. Decided to give poly lab medic a try 2 weeks ago. Last few days yellow tang hasn't been feeding, tonight I noticed it's mouth is kind of fixed in the open position and it's breathing is rapid. Out came the test kits and I've now got an ammonia spike. All fish and cuc accounted for so nothing dead causing it. Could it somehow be linked to the treatment? Have dosed with prime to try and neutralise it a bit and I'm getting water ready for a 15% change tomorrow. Any thoughts or advice would be much appreciated Thanks
     
  2. jim_fitz

    jim_fitz Admin Staff Member

    Joined:
    Mar 20, 2013
    Messages:
    2,790
    Likes Received:
    88
    If the fish aren’t feeding
    Are you still adding food
     
  3. damo666

    damo666 Registered

    Joined:
    Dec 20, 2016
    Messages:
    264
    Likes Received:
    17
    Hi Jim. Apologies if I wasn't clear, covering 3 separate issues above. All fish have been feeding normally, it is only the yellow tang who's mouth is stuck open that is unable to feed
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice