1. Welcome to The Salty Box, a forum to discuss everything related to Marine & Reef Fish keeping in a friendly surrounding.

    Your voice is missing! You will need to register to be able to join in discussions with others.

    We hope to see you as a part of our community soon

    Dismiss Notice

halfords

Discussion in 'General Chit Chat' started by chester_lad, Nov 11, 2013.

  1. chester_lad

    chester_lad Registered

    Joined:
    Apr 22, 2012
    Messages:
    898
    Likes Received:
    0
    hi all long story short car wouldnt start on sunday bumped it and it went but battery light on so took to halfords bloke comes out with his tester and says the battery on car is gone its only showing 11v and 80amps instead of 12v 480amp . so changed battery car started no problems went on a long test drive every think ok today wife goes work on way to pick me up battery light on dash on again battery flat .

    have halfords done me ? could i take battery back was 96 pound but they have my battery they may have scrapped it .

    what to do ?
     
  2. chippypah

    chippypah Registered

    Joined:
    May 23, 2010
    Messages:
    6,426
    Likes Received:
    4
    Is it charging OK, as battery light on shows not.
     
  3. Cleggy1981

    Cleggy1981 Registered

    Joined:
    Jan 20, 2011
    Messages:
    570
    Likes Received:
    0
    Sounds like the alternator mate. They will say that it had damaged the battery so was needed. But now they will sting you for an alternator
     
  4. chester_lad

    chester_lad Registered

    Joined:
    Apr 22, 2012
    Messages:
    898
    Likes Received:
    0
    wont be getting alternator done by halfords. i think its that too . so i didnt need new battey hoping i can take this one back for refund
     
  5. mattrtby

    mattrtby Registered

    Joined:
    Jul 20, 2013
    Messages:
    42
    Likes Received:
    0
    yeah i would say alternator to pal or maybe a broken/loose or corroded wire to it.
     
  6. Tbert33

    Tbert33 Registered

    Joined:
    Mar 20, 2013
    Messages:
    1,759
    Likes Received:
    0
    I had a similar thing with my old mini. Paid for a new battery, new plugs and leads etc only to find out it was the alternator that was nakard.
     
  7. ged@fishnochips

    [email protected] Registered

    Joined:
    Nov 10, 2011
    Messages:
    11,630
    Likes Received:
    2
    My van had the same symptons, and it was the alternator mate.
     
  8. Cleggy1981

    Cleggy1981 Registered

    Joined:
    Jan 20, 2011
    Messages:
    570
    Likes Received:
    0
    What car is it I know some are prone to wiring faults
     
  9. Cleggy1981

    Cleggy1981 Registered

    Joined:
    Jan 20, 2011
    Messages:
    570
    Likes Received:
    0
    But chances are alt
     
  10. chester_lad

    chester_lad Registered

    Joined:
    Apr 22, 2012
    Messages:
    898
    Likes Received:
    0
    audi tt cab just done the tt secret code on the climate control and it says volts was 13.2 with out any thing on soon as i put lights on down to 12 then 11 then 10 so checked belts all tight and wires are ok so alts gone .

    not spending penny on it as we had a accident in it last month and waiting on insurance to collect to look at damge so its a hire car for us . .
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice